Mongo 0.0.6
A pure Fantom driver for MongoDB v2.6+

Mongo is a pure Fantom driver for MongoDB v2.6+.

Mongo driver features:

  • Standard and capped collections
  • Write commands: insert(), update(), delete() and findAndModify() (v2.6+)
  • Write concern support (v2.6+)
  • Optimised queries for findOne() and findAll()
  • Cursor support
  • Aggregation commands: aggregate(), distinct(), group() and mapReduce()
  • Index support: create(), ensure() and drop()
  • User support: create(), drop(), grant() and revoke() roles
  • Database authentication
  • Server side eval() commands
  • Pooled connection manager for multi-threaded use

Mongo driver has been written specifically for MongoDB v2.6.0 released on 8th April 2014, or newer.

Many features, including ALL write commands, will NOT work with older MongoDB versions.

ALIEN-AID: See Morphia for a complete Fantom to MongoDB object mapping library!

Read more...

Install

To install Mongo with Fantom Pod Manager, cut'n'paste the following into a cmd prompt, terminal or shell:

Or to install Mongo with the Fantom Repository Manager (fanr), cut'n'paste the following into a cmd prompt, terminal or shell:

Or to install manually, download the pod file and copy it to the %FAN_HOME%/lib/fan/ directory.

afMongo.pod (101.98 kB)

Use

To use Mongo in a Fantom project, add a dependency to the project's build.fan:

depends = ["sys 1.0", ..., "afMongo 0.0.6 - 0.0"]

Documentation

Information

Meta information on the Mongo pod:

Published by
Steve Eynon
Organisation
Alien-Factory
Pod file size
101.98 kB
Licence
The MIT Licence
Built on
20th Jun 2014
Source code
at https://bitbucket.org/AlienFactory/afmongo
Depends on
afBson, afConcurrent, concurrent, inet, sys
Referenced by
Javascript Compatible
No

Dependency Graph

  Use mouse to re-position pods

Release History

There have been 16 releases of Mongo: